// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^([A-Z|a-z|0-9]{4},)*[A-Z|a-z|0-9]{4}$").unwrap();
let string = "COM1,COM2,COM3,1234
COM,1234,COM,1234
1234,1234,34F
1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}