$re = '/^([A-Z|a-z|0-9]{4},)*[A-Z|a-z|0-9]{4}$/im';
$str = 'COM1,COM2,COM3,1234
COM,1234,COM,1234
1234,1234,34F
1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);