#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*youtube)(?=.*cat)"
Local $sString = "This lookahead search is case sensitive." & @CRLF & _
"This this have cat in it?" & @CRLF & _
"Does this make a match for Youtube?" & @CRLF & _
"What about this youtube and CAT?" & @CRLF & _
"What about cat and YOUTUBE?" & @CRLF & _
"Here is youtube and cat" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")