import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*youtube)(?=.*cat)";
final String string = "This lookahead search is case sensitive.\n"
+ "This this have cat in it?\n"
+ "Does this make a match for Youtube?\n"
+ "What about this youtube and CAT?\n"
+ "What about cat and YOUTUBE?\n"
+ "Here is youtube and cat\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}