re = /(?=.*youtube)(?=.*cat)/m
str = 'This lookahead search is case sensitive.
This this have cat in it?
Does this make a match for Youtube?
What about this youtube and CAT?
What about cat and YOUTUBE?
Here is youtube and cat
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end