import re
regex = re.compile(r"(?=.*youtube)(?=.*cat)", flags=re.MULTILINE)
test_str = ("This lookahead search is case sensitive.\n"
"This this have cat in it?\n"
"Does this make a match for Youtube?\n"
"What about this youtube and CAT?\n"
"What about cat and YOUTUBE?\n"
"Here is youtube and cat\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")