$re = '/(?=.*youtube)(?=.*cat)/m';
$str = 'This lookahead search is case sensitive.
This this have cat in it?
Does this make a match for Youtube?
What about this youtube and CAT?
What about cat and YOUTUBE?
Here is youtube and cat
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);