#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?is)(?<=\NAME1\b).*?(?=\bNAME2\b|\bNAME3\b|NAME4|NAME5|NAME6\b)"
Local $sString = "NAME1 THIS IS ONLY A TEST DATA" & @CRLF & _
"THIS IS NOT THE ACTUAL DATA" & @CRLF & _
"NAME2" & @CRLF & _
"NAME1 THIS IS ONLY A TEST DATA" & @CRLF & _
"THIS IS NOT THE ACTUAL DATA" & @CRLF & _
"NAME3" & @CRLF & _
"NAME1 THIS IS ONLY A TEST DATA" & @CRLF & _
"THIS IS NOT THE ACTUAL DATA" & @CRLF & _
"NAME6" & @CRLF & _
"NAME1 THIS IS ONLY A TEST DATA" & @CRLF & _
"THIS IS NOT THE ACTUAL DATA" & @CRLF & _
"NAME5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")