using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?is)(?<=\NAME1\b).*?(?=\bNAME2\b|\bNAME3\b|NAME4|NAME5|NAME6\b)";
string input = @"NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME2
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME3
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME6
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}