re = /(?is)(?<=\NAME1\b).*?(?=\bNAME2\b|\bNAME3\b|NAME4|NAME5|NAME6\b)/m
str = 'NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME2
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME3
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME6
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end