import Foundation
let pattern = #"(?is)(?<=\NAME1\b).*?(?=\bNAME2\b|\bNAME3\b|NAME4|NAME5|NAME6\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME2
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME3
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME6
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)