use strict;
my $str = 'NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME2
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME3
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME6
NAME1 THIS IS ONLY A TEST DATA
THIS IS NOT THE ACTUAL DATA
NAME5';
my $regex = qr/(?is)(?<=\NAME1\b).*?(?=\bNAME2\b|\bNAME3\b|NAME4|NAME5|NAME6\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}