import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?is)(?<=\\NAME1\\b).*?(?=\\bNAME2\\b|\\bNAME3\\b|NAME4|NAME5|NAME6\\b)";
final String string = "NAME1 THIS IS ONLY A TEST DATA\n"
+ "THIS IS NOT THE ACTUAL DATA\n"
+ "NAME2\n"
+ "NAME1 THIS IS ONLY A TEST DATA\n"
+ "THIS IS NOT THE ACTUAL DATA\n"
+ "NAME3\n"
+ "NAME1 THIS IS ONLY A TEST DATA\n"
+ "THIS IS NOT THE ACTUAL DATA\n"
+ "NAME6\n"
+ "NAME1 THIS IS ONLY A TEST DATA\n"
+ "THIS IS NOT THE ACTUAL DATA\n"
+ "NAME5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}