#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{8,12})"
Local $sString = "Widget1 - Obsolete Use Alternative 56789100" & @CRLF & _
"Obsolete Widget 2 - Use Alternative 56789100 - Blah Blah Blah" & @CRLF & _
"Alternative Use 9999999910 - Blah Blah Blah" & @CRLF & _
"Obsolete use 99999999911"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")