const regex = new RegExp('(\\d{8,12})', 'gm')
const str = `Widget1 - Obsolete Use Alternative 56789100
Obsolete Widget 2 - Use Alternative 56789100 - Blah Blah Blah
Alternative Use 9999999910 - Blah Blah Blah
Obsolete use 99999999911`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}