// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{8,12})").unwrap();
let string = "Widget1 - Obsolete Use Alternative 56789100
Obsolete Widget 2 - Use Alternative 56789100 - Blah Blah Blah
Alternative Use 9999999910 - Blah Blah Blah
Obsolete use 99999999911";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}