$re = '/(\d{8,12})/m';
$str = 'Widget1 - Obsolete Use Alternative 56789100
Obsolete Widget 2 - Use Alternative 56789100 - Blah Blah Blah
Alternative Use 9999999910 - Blah Blah Blah
Obsolete use 99999999911';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);