package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{8,12})`)
var str = `Widget1 - Obsolete Use Alternative 56789100
Obsolete Widget 2 - Use Alternative 56789100 - Blah Blah Blah
Alternative Use 9999999910 - Blah Blah Blah
Obsolete use 99999999911`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}