re = /(\d{8,12})/m
str = 'Widget1 - Obsolete Use Alternative 56789100
Obsolete Widget 2 - Use Alternative 56789100 - Blah Blah Blah
Alternative Use 9999999910 - Blah Blah Blah
Obsolete use 99999999911'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end