use strict;
my $str = '// Should pass
"doubleQuotes"
\'singleQuote\'
"thisis\'single\'insideDouble"
\'thisis"double"insidesSingle\'
`this is sometext inside back quote`
"sample\\"app\\""
// Should fail
"thisis"double"insidesDouble"
\'thisis\'single\'insidesSingle\'
`this is sometext `inside` back quote`';
my $regex = qr/^("([^"]|\\")*?")$|^('([^']|\\')*?')$|^(`([^`]|\\`)*?`)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}