re = /^("([^"]|\\")*?")$|^('([^']|\\')*?')$|^(`([^`]|\\`)*?`)$/m
str = '// Should pass
"doubleQuotes"
\'singleQuote\'
"thisis\'single\'insideDouble"
\'thisis"double"insidesSingle\'
`this is sometext inside back quote`
"sample\\"app\\""
// Should fail
"thisis"double"insidesDouble"
\'thisis\'single\'insidesSingle\'
`this is sometext `inside` back quote`'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end