// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^("([^"]|\\")*?")$|^('([^']|\\')*?')$|^(`([^`]|\\`)*?`)$"#).unwrap();
let string = "// Should pass
\"doubleQuotes\"
'singleQuote'
\"thisis'single'insideDouble\"
'thisis\"double\"insidesSingle'
`this is sometext inside back quote`
\"sample\\\"app\\\"\"
// Should fail
\"thisis\"double\"insidesDouble\"
'thisis'single'insidesSingle'
`this is sometext `inside` back quote`";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}