# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\w\.]*\w+\..*?(?=,|\s|$)\K/\/whatever/g;t' <<< "You can go to www.google.com, or if you want a different engine, you can go to https://www.bing.com, whichever you prefer"