import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w\\.]*\\w+\\..*?(?=,|\\s|$)\\K";
final String string = "You can go to www.google.com, or if you want a different engine, you can go to https://www.bing.com, whichever you prefer";
final String subst = "/whatever";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}