const regex = /[\w\.]*\w+\..*?(?=,|\s|$)\K/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w\\.]*\\w+\\..*?(?=,|\\s|$)\\K', 'g')
const str = `You can go to www.google.com, or if you want a different engine, you can go to https://www.bing.com, whichever you prefer`;
const subst = `/whatever`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);