using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w\.]*\w+\..*?(?=,|\s|$)\K";
string substitution = @"/whatever";
string input = @"You can go to www.google.com, or if you want a different engine, you can go to https://www.bing.com, whichever you prefer";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}