#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\.*section\{((?!.*\\status.*\{\})[^}]+)}"
Local $sString = "\subsection{Hello} -> "\subsection”, "Hello"" & @CRLF & _
"\section{Foobar} -> "\section", "Foobar"" & @CRLF & _
"\subsubsection{This is a Triumph} -> "\subsubsection", "This is a Triumph"" & @CRLF & _
"" & @CRLF & _
"\subsection{Hello\statusdone{}}" & @CRLF & _
"\section{Hello World\statuswip{}}" & @CRLF & _
"\section{Everything\statusproofreading{}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")