re = /\\.*section\{((?!.*\\status.*\{\})[^}]+)}/m
str = '\\subsection{Hello} -> "\\subsection”, "Hello"
\\section{Foobar} -> "\\section", "Foobar"
\\subsubsection{This is a Triumph} -> "\\subsubsection", "This is a Triumph"
\\subsection{Hello\\statusdone{}}
\\section{Hello World\\statuswip{}}
\\section{Everything\\statusproofreading{}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end