$re = '/\\\\.*section\{((?!.*\\\\status.*\{\})[^}]+)}/m';
$str = '\\subsection{Hello} -> "\\subsection”, "Hello"
\\section{Foobar} -> "\\section", "Foobar"
\\subsubsection{This is a Triumph} -> "\\subsubsection", "This is a Triumph"
\\subsection{Hello\\statusdone{}}
\\section{Hello World\\statuswip{}}
\\section{Everything\\statusproofreading{}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);