const regex = /\\.*section\{((?!.*\\status.*\{\})[^}]+)}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\.*section\\{((?!.*\\\\status.*\\{\\})[^}]+)}', 'gm')
const str = `\\subsection{Hello} -> "\\subsection”, "Hello"
\\section{Foobar} -> "\\section", "Foobar"
\\subsubsection{This is a Triumph} -> "\\subsubsection", "This is a Triumph"
\\subsection{Hello\\statusdone{}}
\\section{Hello World\\statuswip{}}
\\section{Everything\\statusproofreading{}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}