import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\.*section\\{((?!.*\\\\status.*\\{\\})[^\\}]+)\\}";
final String string = "\\subsection{Hello} -> \"\\subsection”, \"Hello\"\n"
+ "\\section{Foobar} -> \"\\section\", \"Foobar\"\n"
+ "\\subsubsection{This is a Triumph} -> \"\\subsubsection\", \"This is a Triumph\"\n\n"
+ "\\subsection{Hello\\statusdone{}}\n"
+ "\\section{Hello World\\statuswip{}}\n"
+ "\\section{Everything\\statusproofreading{}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}