using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\.*section\{((?!.*\\status.*\{\})[^}]+)}";
string input = @"\subsection{Hello} -> ""\subsection”, ""Hello""
\section{Foobar} -> ""\section"", ""Foobar""
\subsubsection{This is a Triumph} -> ""\subsubsection"", ""This is a Triumph""
\subsection{Hello\statusdone{}}
\section{Hello World\statuswip{}}
\section{Everything\statusproofreading{}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}