using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[video=peertube\](https\:\/\/.*?\/videos\/)watch(\/.{36})\[\/video\]";
string substitution = @"\1embed\2";
string input = @"[video=peertube]https://9chen.org/videos/watch/9c9de5e8-0a1e-484a-b099-e80766180a6d[/video]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}