use strict;
my $str = '[video=peertube]https://9chen.org/videos/watch/9c9de5e8-0a1e-484a-b099-e80766180a6d[/video]';
my $regex = qr/\[video=peertube\](https\:\/\/.*?\/videos\/)watch(\/.{36})\[\/video\]/mp;
my $subst = '\\1embed\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";