import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[video=peertube\\](https\\:\\/\\/.*?\\/videos\\/)watch(\\/.{36})\\[\\/video\\]";
final String string = "[video=peertube]https://9chen.org/videos/watch/9c9de5e8-0a1e-484a-b099-e80766180a6d[/video]";
final String subst = "\\1embed\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}