import Foundation
let pattern = #"\[video=peertube\](https\:\/\/.*?\/videos\/)watch(\/.{36})\[\/video\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[video=peertube]https://9chen.org/videos/watch/9c9de5e8-0a1e-484a-b099-e80766180a6d[/video]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1embed\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)