const regex = /\[video=peertube\](https\:\/\/.*?\/videos\/)watch(\/.{36})\[\/video\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[video=peertube\\](https\\:\\\/\\\/.*?\\\/videos\\\/)watch(\\\/.{36})\\[\\\/video\\]', 'gm')
const str = `[video=peertube]https://9chen.org/videos/watch/9c9de5e8-0a1e-484a-b099-e80766180a6d[/video]`;
const subst = `\1embed\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);