# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[video=peertube\](https\:\/\/.*?\/videos\/)watch(\/.{36})\[\/video\]"
test_str = "[video=peertube]https://9chen.org/videos/watch/9c9de5e8-0a1e-484a-b099-e80766180a6d[/video]"
subst = "\\1embed\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.