package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\d+) )(.+)`)
var str = `30304 Homer Simpson1
30305 Homer Simpson2
30306 Homer Simpson3
30307 Homer J Simpson4
30308 Homer Simpson5
30309 Homer Simpson6
30310 Homer Pete Simpson7
30311 Homer Simpson8
30312 Homer Simpson9
30313 Homer Simpson10
30314 Homer Simpson11
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}