// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((\d+) )(.+)").unwrap();
let string = "30304 Homer Simpson1
30305 Homer Simpson2
30306 Homer Simpson3
30307 Homer J Simpson4
30308 Homer Simpson5
30309 Homer Simpson6
30310 Homer Pete Simpson7
30311 Homer Simpson8
30312 Homer Simpson9
30313 Homer Simpson10
30314 Homer Simpson11
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}