use strict;
my $str = '30304 Homer Simpson1
30305 Homer Simpson2
30306 Homer Simpson3
30307 Homer J Simpson4
30308 Homer Simpson5
30309 Homer Simpson6
30310 Homer Pete Simpson7
30311 Homer Simpson8
30312 Homer Simpson9
30313 Homer Simpson10
30314 Homer Simpson11
';
my $regex = qr/((\d+) )(.+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}