import re
regex = re.compile(r"((\d+) )(.+)")
test_str = ("30304 Homer Simpson1\n"
"30305 Homer Simpson2\n"
"30306 Homer Simpson3\n"
"30307 Homer J Simpson4\n"
"30308 Homer Simpson5\n"
"30309 Homer Simpson6\n"
"30310 Homer Pete Simpson7\n"
"30311 Homer Simpson8\n"
"30312 Homer Simpson9\n"
"30313 Homer Simpson10\n"
"30314 Homer Simpson11\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")