const regex = /((\d+) )(.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d+) )(.+)', 'g')
const str = `30304 Homer Simpson1
30305 Homer Simpson2
30306 Homer Simpson3
30307 Homer J Simpson4
30308 Homer Simpson5
30309 Homer Simpson6
30310 Homer Pete Simpson7
30311 Homer Simpson8
30312 Homer Simpson9
30313 Homer Simpson10
30314 Homer Simpson11
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}