package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\{\d+}`)
var str = `{12313}Luglio
{34}Maggio`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}