use strict;
my $str = '{12313}Luglio
{34}Maggio';
my $regex = qr/^\{\d+}/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";