const regex = new RegExp('^\\{\\d+}', 'gm')
const str = `{12313}Luglio
{34}Maggio`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);