import re
regex = re.compile(r"^\{\d+}", flags=re.MULTILINE)
test_str = ("{12313}Luglio\n"
"{34}Maggio")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)