#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\d{3}\s)([A-Za-z\.]*)\s([A-Za-z\.]*)"
Local $sString = "009 G Nantpaipakdee 38 955 722 650-240-0111" & @CRLF & _
"002 Eugénie Romette 432 734 782" & @CRLF & _
"005 Christina Pandullo 410-527-8241 410-527-8158" & @CRLF & _
"020 Joe Smith 410-771-7815 410-527-8771" & @CRLF & _
"030 K Kordysiewicz 42 239 3875" & @CRLF & _
"300 Cecile A. Wattiez 432 736 683" & @CRLF & _
"305 Do not use"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")