$re = '/(?<=\d{3}\s)([A-Za-z\.]*)\s([A-Za-z\.]*)/m';
$str = '009 G Nantpaipakdee 38 955 722 650-240-0111
002 Eugénie Romette 432 734 782
005 Christina Pandullo 410-527-8241 410-527-8158
020 Joe Smith 410-771-7815 410-527-8771
030 K Kordysiewicz 42 239 3875
300 Cecile A. Wattiez 432 736 683
305 Do not use';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);