use strict;
my $str = '009 G Nantpaipakdee 38 955 722 650-240-0111
002 Eugénie Romette 432 734 782
005 Christina Pandullo 410-527-8241 410-527-8158
020 Joe Smith 410-771-7815 410-527-8771
030 K Kordysiewicz 42 239 3875
300 Cecile A. Wattiez 432 736 683
305 Do not use';
my $regex = qr/(?<=\d{3}\s)([A-Za-z\.]*)\s([A-Za-z\.]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}